summaryrefslogtreecommitdiffstats
path: root/testsuites/tmtests/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2014-07-10 14:20:39 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2014-07-14 19:31:00 -0500
commitb6343c61002b421e4d578e9868bedc1f0f0b43d7 (patch)
tree5c26dfacce2523537cb201e5f07de599cf454901 /testsuites/tmtests/Makefile.am
parentcapture01: Add include of assert.h. (diff)
downloadrtems-b6343c61002b421e4d578e9868bedc1f0f0b43d7.tar.bz2
Enhance Semaphore Blocking and Readying Time Test Cases
tm02 and tm03 were modified to be reused for multiple configurations of RTEMS Classic API Semaphores. This added tm31-36. The messages for tm02 and tm03 were modified to indicate the semaphore attributes. tm31 - tm36 were added. This resulted in the following cases: tm02 - rtems_semaphore_obtain: Counting/FIFO not available caller blocks tm03 - rtems_semaphore_release: Counting/FIFO task readied preempts caller tm31 - rtems_semaphore_obtain: Counting/priority not available caller blocks tm32 - rtems_semaphore_release: Counting/priority task readied preempts caller tm33 - rtems_semaphore_obtain: Binary/FIFO not available caller blocks tm34 - rtems_semaphore_release: Binary/FIFO task readied preempts caller tm35 - rtems_semaphore_obtain: Binary/priority not available caller blocks tm36 - rtems_semaphore_release: Binary/priority task readied preempts caller
Diffstat (limited to 'testsuites/tmtests/Makefile.am')
-rw-r--r--testsuites/tmtests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/testsuites/tmtests/Makefile.am b/testsuites/tmtests/Makefile.am
index 7d98a024a2..bab9e806bb 100644
--- a/testsuites/tmtests/Makefile.am
+++ b/testsuites/tmtests/Makefile.am
@@ -2,7 +2,7 @@ ACLOCAL_AMFLAGS = -I ../aclocal
_SUBDIRS = tmck tmoverhd tm01 tm02 tm03 tm04 tm05 tm06 tm07 tm08 tm09 tm10 \
tm11 tm12 tm13 tm14 tm15 tm16 tm17 tm18 tm19 tm20 tm21 tm22 tm23 tm24 \
- tm25 tm26 tm27 tm28 tm29 tm30
+ tm25 tm26 tm27 tm28 tm29 tm30 tm31 tm32 tm33 tm34 tm35 tm36
_SUBDIRS += tmcontext01
include $(top_srcdir)/../automake/test-subdirs.am