summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/spprofiling01/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-03-10 14:39:49 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-03-14 08:46:49 +0100
commit4dad4b84112d57cf6e77409f8e267706db446ec0 (patch)
tree6af69b581cc801a3f8355b9188ae98012f85f4af /testsuites/sptests/spprofiling01/Makefile.am
parentscore: Add --enable-profiling configure option (diff)
downloadrtems-4dad4b84112d57cf6e77409f8e267706db446ec0.tar.bz2
sapi: Add profiling application level support
Diffstat (limited to 'testsuites/sptests/spprofiling01/Makefile.am')
-rw-r--r--testsuites/sptests/spprofiling01/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/testsuites/sptests/spprofiling01/Makefile.am b/testsuites/sptests/spprofiling01/Makefile.am
new file mode 100644
index 0000000000..872e50a712
--- /dev/null
+++ b/testsuites/sptests/spprofiling01/Makefile.am
@@ -0,0 +1,19 @@
+rtems_tests_PROGRAMS = spprofiling01
+spprofiling01_SOURCES = init.c
+
+dist_rtems_tests_DATA = spprofiling01.scn spprofiling01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(spprofiling01_OBJECTS)
+LINK_LIBS = $(spprofiling01_LDLIBS)
+
+spprofiling01$(EXEEXT): $(spprofiling01_OBJECTS) $(spprofiling01_DEPENDENCIES)
+ @rm -f spprofiling01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am