summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/spnotepad01/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-09-29 00:06:43 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-09-29 00:06:43 +0000
commit5fc4c4b5ffe5ca8a85335aa2eecc0d6948187aee (patch)
treecc970aa69a4879f0097820a4875de3a47cba77d6 /testsuites/sptests/spnotepad01/Makefile.am
parent2009-09-28 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-5fc4c4b5ffe5ca8a85335aa2eecc0d6948187aee.tar.bz2
2009-09-28 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac: Add new test to exercise when notepads are not configured. * spnotepad01/.cvsignore, spnotepad01/Makefile.am, spnotepad01/init.c, spnotepad01/spnotepad01.doc, spnotepad01/spnotepad01.scn: New files.
Diffstat (limited to 'testsuites/sptests/spnotepad01/Makefile.am')
-rw-r--r--testsuites/sptests/spnotepad01/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/sptests/spnotepad01/Makefile.am b/testsuites/sptests/spnotepad01/Makefile.am
new file mode 100644
index 0000000000..75daa1521b
--- /dev/null
+++ b/testsuites/sptests/spnotepad01/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = spnotepad01
+spnotepad01_SOURCES = init.c
+
+dist_rtems_tests_DATA = spnotepad01.scn
+dist_rtems_tests_DATA += spnotepad01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+spnotepad01_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(spnotepad01_OBJECTS) $(spnotepad01_LDADD)
+LINK_LIBS = $(spnotepad01_LDLIBS)
+
+spnotepad01$(EXEEXT): $(spnotepad01_OBJECTS) $(spnotepad01_DEPENDENCIES)
+ @rm -f spnotepad01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am