summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/spinternalerror01/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2012-11-07 12:31:27 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2012-11-13 09:37:57 +0100
commit44633fd65cf04f64203cb6137435a18135502842 (patch)
treee22dee2766eba3b259aeaf1b443cb6eb825103d0 /testsuites/sptests/spinternalerror01/Makefile.am
parentscore: Move global variables definition (diff)
downloadrtems-44633fd65cf04f64203cb6137435a18135502842.tar.bz2
sptests/spinternalerror01: New test
Diffstat (limited to 'testsuites/sptests/spinternalerror01/Makefile.am')
-rw-r--r--testsuites/sptests/spinternalerror01/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/testsuites/sptests/spinternalerror01/Makefile.am b/testsuites/sptests/spinternalerror01/Makefile.am
new file mode 100644
index 0000000000..0f8d985aa5
--- /dev/null
+++ b/testsuites/sptests/spinternalerror01/Makefile.am
@@ -0,0 +1,19 @@
+rtems_tests_PROGRAMS = spinternalerror01
+spinternalerror01_SOURCES = init.c
+
+dist_rtems_tests_DATA = spinternalerror01.scn spinternalerror01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(spinternalerror01_OBJECTS)
+LINK_LIBS = $(spinternalerror01_LDLIBS)
+
+spinternalerror01$(EXEEXT): $(spinternalerror01_OBJECTS) $(spinternalerror01_DEPENDENCIES)
+ @rm -f spinternalerror01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am