summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/spfatal26/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2012-11-25 17:48:11 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2012-11-27 17:03:40 +0100
commit815994fd17c2f732aacaf273a1e476a62de5f4a6 (patch)
tree17fffb992fcf3e025462215ee3c7515919d2ced4 /testsuites/sptests/spfatal26/Makefile.am
parentpowerpc: Add CPU_Exception_frame (diff)
downloadrtems-815994fd17c2f732aacaf273a1e476a62de5f4a6.tar.bz2
score: Add CPU_Exception_frame
Add CPU port type CPU_Exception_frame and function _CPU_Exception_frame_print(). The CPU ports of avr, bfin, h8300, lm32, m32c, m32r, m68k, nios2, sh, sparc64, and v850 use an empty default implementation of _CPU_Exception_frame_print(). Add rtems_exception_frame and rtems_exception_frame_print(). Add RTEMS_FATAL_SOURCE_EXCEPTION for CPU exceptions. Use rtems_fatal() with source RTEMS_FATAL_SOURCE_EXCEPTION in CPU ports of i386, powerpc, and sparc for unexpected exceptions. Add third parameter to RTEMS_BSP_CLEANUP_OPTIONS() which controls the BSP_PRINT_EXCEPTION_CONTEXT define used in the default bsp_fatal_extension(). Add test sptests/spfatal26.
Diffstat (limited to 'testsuites/sptests/spfatal26/Makefile.am')
-rw-r--r--testsuites/sptests/spfatal26/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/testsuites/sptests/spfatal26/Makefile.am b/testsuites/sptests/spfatal26/Makefile.am
new file mode 100644
index 0000000000..9cc5dbac1c
--- /dev/null
+++ b/testsuites/sptests/spfatal26/Makefile.am
@@ -0,0 +1,19 @@
+rtems_tests_PROGRAMS = spfatal26
+spfatal26_SOURCES = init.c
+
+dist_rtems_tests_DATA = spfatal26.scn spfatal26.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(spfatal26_OBJECTS)
+LINK_LIBS = $(spfatal26_LDLIBS)
+
+spfatal26$(EXEEXT): $(spfatal26_OBJECTS) $(spfatal26_DEPENDENCIES)
+ @rm -f spfatal26$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am