summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/spfatal10/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-12-15 19:21:10 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-12-15 19:21:10 +0000
commitbb9c80df457c8c054ae99508fed4959886f78930 (patch)
treebb80894b267958d9566904c06c951ca85d2222a7 /testsuites/sptests/spfatal10/Makefile.am
parent2008-12-15 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-bb9c80df457c8c054ae99508fed4959886f78930.tar.bz2
2008-12-15 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac, spfatal06/testcase.h, spfatal07/testcase.h, spfatal08/testcase.h, spfatal09/testcase.h, spsize/size.c: Eliminate pointers to API configuration tables in the main configuration table. Reference the main configuration table and the API configuration tables directly using the confdefs.h version rather than obtaining a pointer to it. This eliminated some variables, a potential fatal error, some unnecessary default configuration structures. Overall, about a 4.5% reduction in the code size for minimum and hello on the SPARC. * spfatal10/.cvsignore, spfatal10/Makefile.am, spfatal10/spfatal10.scn, spfatal10/testcase.h: Removed.
Diffstat (limited to 'testsuites/sptests/spfatal10/Makefile.am')
-rw-r--r--testsuites/sptests/spfatal10/Makefile.am27
1 files changed, 0 insertions, 27 deletions
diff --git a/testsuites/sptests/spfatal10/Makefile.am b/testsuites/sptests/spfatal10/Makefile.am
deleted file mode 100644
index 286fd3a9f2..0000000000
--- a/testsuites/sptests/spfatal10/Makefile.am
+++ /dev/null
@@ -1,27 +0,0 @@
-##
-## $Id$
-##
-
-MANAGERS = all
-
-rtems_tests_PROGRAMS = spfatal10.exe
-spfatal10_exe_SOURCES = ../spfatal_support/init.c ../spfatal_support/system.h testcase.h
-
-dist_rtems_tests_DATA = spfatal10.scn
-
-include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../automake/compile.am
-include $(top_srcdir)/../automake/leaf.am
-
-spfatal10_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
-
-AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-
-LINK_OBJS = $(spfatal10_exe_OBJECTS) $(spfatal10_exe_LDADD)
-LINK_LIBS = $(spfatal10_exe_LDLIBS)
-
-spfatal10.exe$(EXEEXT): $(spfatal10_exe_OBJECTS) $(spfatal10_exe_DEPENDENCIES)
- @rm -f spfatal10.exe$(EXEEXT)
- $(make-exe)
-
-include $(top_srcdir)/../automake/local.am