summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sperror03/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-06-28 14:03:45 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-06-28 14:03:45 +0000
commit0308c028537c525225446005ef051db49a136ba8 (patch)
tree1e37e004af49299e2007bdc03cecc26a49fff1ff /testsuites/sptests/sperror03/Makefile.am
parent2010-06-28 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-0308c028537c525225446005ef051db49a136ba8.tar.bz2
2010-06-26 Bharath Suri <bharath.s.jois@gmail.com>
PR 1592/testing * Makefile.am, configure.ac: Changes to incorporate sperror01, sperror02, sperror03 * sperror01/init.c, sperror02/init.c: New tests to exercise rtems_error routine * sperror03/init.c: New test to exercise rtems_panic routine
Diffstat (limited to 'testsuites/sptests/sperror03/Makefile.am')
-rw-r--r--testsuites/sptests/sperror03/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/testsuites/sptests/sperror03/Makefile.am b/testsuites/sptests/sperror03/Makefile.am
new file mode 100644
index 0000000000..2da638442a
--- /dev/null
+++ b/testsuites/sptests/sperror03/Makefile.am
@@ -0,0 +1,26 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sperror03
+sperror03_SOURCES = init.c
+
+dist_rtems_tests_DATA = sperror03.scn
+dist_rtems_tests_DATA += sperror03.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sperror03_OBJECTS) $(sperror03_LDADD)
+LINK_LIBS = $(sperror03_LDLIBS)
+
+sperror03$(EXEEXT): $(sperror03_OBJECTS) $(sperror03_DEPENDENCIES)
+ @rm -f sperror03$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am