summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/spcpuset01/Makefile.am
diff options
context:
space:
mode:
authorJennifer Averett <jennifer.averett@oarcorp.com>2013-12-16 13:13:14 -0600
committerJennifer Averett <jennifer.averett@oarcorp.com>2013-12-19 14:11:09 -0600
commitfe011a59a4b6fe2879f2c2354e8771c3f8aad6aa (patch)
treedb34e117b4d9add862dc35f3ec0707c8c15be909 /testsuites/sptests/spcpuset01/Makefile.am
parentcpukit/capture: Update the capture engine. (diff)
downloadrtems-fe011a59a4b6fe2879f2c2354e8771c3f8aad6aa.tar.bz2
sptests/spcpuset*: Add tests for fixed size cpu_set_t operations.
This adds five tests for <sys/cpuset.h>. It does not include tests for CPU_XXX_S methods. The autotools should be able to avoid enabling the tests unless the toolset has <sys/cpuset.h>.
Diffstat (limited to 'testsuites/sptests/spcpuset01/Makefile.am')
-rw-r--r--testsuites/sptests/spcpuset01/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/testsuites/sptests/spcpuset01/Makefile.am b/testsuites/sptests/spcpuset01/Makefile.am
new file mode 100644
index 0000000000..61ce023a37
--- /dev/null
+++ b/testsuites/sptests/spcpuset01/Makefile.am
@@ -0,0 +1,22 @@
+
+rtems_tests_PROGRAMS = spcpuset01
+spcpuset01_SOURCES = test.c init.c
+
+dist_rtems_tests_DATA = spcpuset01.scn
+dist_rtems_tests_DATA += spcpuset01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+AM_CPPFLAGS += -DSMPTEST
+
+LINK_OBJS = $(spcpuset01_OBJECTS)
+LINK_LIBS = $(spcpuset01_LDLIBS)
+
+spcpuset01$(EXEEXT): $(spcpuset01_OBJECTS) $(spcpuset01_DEPENDENCIES)
+ @rm -f smp01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am