summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp77/Makefile.am
diff options
context:
space:
mode:
authorKrzysztof Mięsowicz <krzysztof.miesowicz@gmail.com>2012-08-29 07:35:23 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2012-08-29 07:37:01 -0500
commit3913e3cf934d21e3efd80369ef3cf694484a1955 (patch)
tree93bc35b0ca6a91ff78d883dfa5d144262f689f7c /testsuites/sptests/sp77/Makefile.am
parentbsp/mpc55xx: Use a one second timeout (diff)
downloadrtems-3913e3cf934d21e3efd80369ef3cf694484a1955.tar.bz2
sp77: new test to cover allocated message size overflowing
Author: Krzysztof Mięsowicz <krzysztof.miesowicz@gmail.com>
Diffstat (limited to 'testsuites/sptests/sp77/Makefile.am')
-rw-r--r--testsuites/sptests/sp77/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/testsuites/sptests/sp77/Makefile.am b/testsuites/sptests/sp77/Makefile.am
new file mode 100644
index 0000000000..ee3eda773d
--- /dev/null
+++ b/testsuites/sptests/sp77/Makefile.am
@@ -0,0 +1,22 @@
+
+
+rtems_tests_PROGRAMS = sp77
+sp77_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp77.scn
+dist_rtems_tests_DATA += sp77.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp77_OBJECTS) $(sp77_LDADD)
+LINK_LIBS = $(sp77_LDLIBS)
+
+sp77$(EXEEXT): $(sp77_OBJECTS) $(sp77_DEPENDENCIES)
+ @rm -f sp77$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am