summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp75/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-07-26 20:53:09 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-07-26 20:53:09 +0000
commit6b95d5c0f78010c490fe568151be29ab16dcb538 (patch)
tree468ae51df7b295f623af01e19608c8222aab27ee /testsuites/sptests/sp75/Makefile.am
parent2011-07-26 Joel Sherrill <joel.sherrilL@OARcorp.com> (diff)
downloadrtems-6b95d5c0f78010c490fe568151be29ab16dcb538.tar.bz2
2011-07-26 Joel Sherrill <joel.sherrilL@OARcorp.com>
* Makefile.am, configure.ac: New test to get coverage of core mutex obtain while in ISR or other dispatch disabled critical section but no wait. * sp75/.cvsignore, sp75/Makefile.am, sp75/init.c, sp75/sp75.doc, sp75/sp75.scn: New files.
Diffstat (limited to 'testsuites/sptests/sp75/Makefile.am')
-rw-r--r--testsuites/sptests/sp75/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/testsuites/sptests/sp75/Makefile.am b/testsuites/sptests/sp75/Makefile.am
new file mode 100644
index 0000000000..badddbc1dd
--- /dev/null
+++ b/testsuites/sptests/sp75/Makefile.am
@@ -0,0 +1,26 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp75
+sp75_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp75.scn
+dist_rtems_tests_DATA += sp75.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp75_OBJECTS) $(sp75_LDADD)
+LINK_LIBS = $(sp75_LDLIBS)
+
+sp75$(EXEEXT): $(sp75_OBJECTS) $(sp75_DEPENDENCIES)
+ @rm -f sp75$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am