summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp69/Makefile.am
diff options
context:
space:
mode:
authorGlenn Humphrey <glenn.humphrey@oarcorp.com>2009-12-08 23:07:38 +0000
committerGlenn Humphrey <glenn.humphrey@oarcorp.com>2009-12-08 23:07:38 +0000
commit7199b1d0dcd4d56ffd7c21091a1e62c6a799cf06 (patch)
tree8ba8556c261558a1814a30bbee121a2c2d0f7657 /testsuites/sptests/sp69/Makefile.am
parent2009-12-08 Glenn Humphrey <glenn.humphrey@OARcorp.com> (diff)
downloadrtems-7199b1d0dcd4d56ffd7c21091a1e62c6a799cf06.tar.bz2
2009-12-08 Glenn Humphrey <glenn.humphrey@OARcorp.com>
* Makefile.am, configure.ac: Added a test for rate_monotonic_get_status to ensure that all paths are tested. * sp69/Makefile.am, sp69/init.c, sp69/sp69.doc, sp69/sp69.scn: New files.
Diffstat (limited to 'testsuites/sptests/sp69/Makefile.am')
-rw-r--r--testsuites/sptests/sp69/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/sptests/sp69/Makefile.am b/testsuites/sptests/sp69/Makefile.am
new file mode 100644
index 0000000000..232f18b624
--- /dev/null
+++ b/testsuites/sptests/sp69/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp69
+sp69_SOURCES = init.c ../../support/src/spin.c
+
+dist_rtems_tests_DATA = sp69.scn
+dist_rtems_tests_DATA += sp69.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp69_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp69_OBJECTS) $(sp69_LDADD)
+LINK_LIBS = $(sp69_LDLIBS)
+
+sp69$(EXEEXT): $(sp69_OBJECTS) $(sp69_DEPENDENCIES)
+ @rm -f sp69$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am