summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp68/Makefile.am
diff options
context:
space:
mode:
authorThomas Doerfler <Thomas.Doerfler@embedded-brains.de>2009-11-30 09:08:35 +0000
committerThomas Doerfler <Thomas.Doerfler@embedded-brains.de>2009-11-30 09:08:35 +0000
commit6e51c4c9f7212bd696ee7aa777c9ca4ac1ad6d3b (patch)
tree0260716bb7c1fc8b80e018924678a0b74a7b42bf /testsuites/sptests/sp68/Makefile.am
parentRegenerate. (diff)
downloadrtems-6e51c4c9f7212bd696ee7aa777c9ca4ac1ad6d3b.tar.bz2
Added timer server control block
Removed _Timer_Server thread pointer Added _Timer_server pointer to the default timer server control block Rework of the timer server implementation.
Diffstat (limited to 'testsuites/sptests/sp68/Makefile.am')
-rw-r--r--testsuites/sptests/sp68/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/sptests/sp68/Makefile.am b/testsuites/sptests/sp68/Makefile.am
new file mode 100644
index 0000000000..00ec200260
--- /dev/null
+++ b/testsuites/sptests/sp68/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp68
+sp68_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp68.scn
+dist_rtems_tests_DATA += sp68.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp68_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp68_OBJECTS) $(sp68_LDADD)
+LINK_LIBS = $(sp68_LDLIBS)
+
+sp68$(EXEEXT): $(sp68_OBJECTS) $(sp68_DEPENDENCIES)
+ @rm -f sp68$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am