summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp63/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-08-01 00:25:20 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-08-01 00:25:20 +0000
commitba23ff5e3685e201d4338f4e1c566a3b84865a69 (patch)
tree0b209d08ed3b23dba9e618169ce3f9d70b8a739b /testsuites/sptests/sp63/Makefile.am
parent2009-07-31 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-ba23ff5e3685e201d4338f4e1c566a3b84865a69.tar.bz2
2009-07-31 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac, sp62/init.c: Add new test to ensure a particular path is taken through the _Heap_Resize_block code. * sp63/.cvsignore, sp63/Makefile.am, sp63/init.c, sp63/sp63.doc, sp63/sp63.scn: New files.
Diffstat (limited to 'testsuites/sptests/sp63/Makefile.am')
-rw-r--r--testsuites/sptests/sp63/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/sptests/sp63/Makefile.am b/testsuites/sptests/sp63/Makefile.am
new file mode 100644
index 0000000000..d53442c0cb
--- /dev/null
+++ b/testsuites/sptests/sp63/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp63
+sp63_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp63.scn
+dist_rtems_tests_DATA += sp63.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp63_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp63_OBJECTS) $(sp63_LDADD)
+LINK_LIBS = $(sp63_LDLIBS)
+
+sp63$(EXEEXT): $(sp63_OBJECTS) $(sp63_DEPENDENCIES)
+ @rm -f sp63$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am