summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp62/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-28 23:49:47 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-28 23:49:47 +0000
commitd2861a11a0841971624f1254a0c41af3e7e0a25a (patch)
tree44641d3aeeeb027d97586c99d002c0851e003535 /testsuites/sptests/sp62/Makefile.am
parent2009-07-28 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-d2861a11a0841971624f1254a0c41af3e7e0a25a.tar.bz2
2009-07-28 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac: Add new test to handle the case where a region resize frees enough memory to unblock a task. * sp62/.cvsignore, sp62/Makefile.am, sp62/init.c, sp62/sp62.doc, sp62/sp62.scn: New files. * sp61/init.c: Test does not need regions.
Diffstat (limited to 'testsuites/sptests/sp62/Makefile.am')
-rw-r--r--testsuites/sptests/sp62/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/sptests/sp62/Makefile.am b/testsuites/sptests/sp62/Makefile.am
new file mode 100644
index 0000000000..79fc768882
--- /dev/null
+++ b/testsuites/sptests/sp62/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp62
+sp62_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp62.scn
+dist_rtems_tests_DATA += sp62.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp62_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp62_OBJECTS) $(sp62_LDADD)
+LINK_LIBS = $(sp62_LDLIBS)
+
+sp62$(EXEEXT): $(sp62_OBJECTS) $(sp62_DEPENDENCIES)
+ @rm -f sp62$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am