summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp60/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-20 01:05:33 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-20 01:05:33 +0000
commitf691e0a09f9ff7b24d482145cf9ae52220ee9b0f (patch)
tree2771b3f59e36fa3bd9b8e10645a735843184b7c1 /testsuites/sptests/sp60/Makefile.am
parent*** empty log message *** (diff)
downloadrtems-f691e0a09f9ff7b24d482145cf9ae52220ee9b0f.tar.bz2
2009-07-19 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac: Add sp60 to exercise case where a task is blocked on one period while another expires. Add sp61 which exercises the case where a call is made to rtems_shutdown_executive when the system is not up. * sp60/.cvsignore, sp60/Makefile.am, sp60/init.c, sp60/sp60.doc, sp60/sp60.scn, sp61/.cvsignore, sp61/Makefile.am, sp61/init.c, sp61/sp61.doc, sp61/sp61.scn: New files.
Diffstat (limited to 'testsuites/sptests/sp60/Makefile.am')
-rw-r--r--testsuites/sptests/sp60/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/sptests/sp60/Makefile.am b/testsuites/sptests/sp60/Makefile.am
new file mode 100644
index 0000000000..b164bef099
--- /dev/null
+++ b/testsuites/sptests/sp60/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp60
+sp60_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp60.scn
+dist_rtems_tests_DATA += sp60.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp60_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp60_OBJECTS) $(sp60_LDADD)
+LINK_LIBS = $(sp60_LDLIBS)
+
+sp60$(EXEEXT): $(sp60_OBJECTS) $(sp60_DEPENDENCIES)
+ @rm -f sp60$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am