summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp58/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-09 18:21:58 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-09 18:21:58 +0000
commitd5ae827a35f837830f49f9cc05a60bb21d01f9c8 (patch)
treeb86be574f67e1386a4f25df02a7356a43894c0b7 /testsuites/sptests/sp58/Makefile.am
parent2009-07-09 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-d5ae827a35f837830f49f9cc05a60bb21d01f9c8.tar.bz2
2009-07-09 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac: Add test for timespec divide by zero. * sp58/.cvsignore, sp58/Makefile.am, sp58/init.c, sp58/sp58.doc, sp58/sp58.scn: New files.
Diffstat (limited to 'testsuites/sptests/sp58/Makefile.am')
-rw-r--r--testsuites/sptests/sp58/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/sptests/sp58/Makefile.am b/testsuites/sptests/sp58/Makefile.am
new file mode 100644
index 0000000000..bb92933d87
--- /dev/null
+++ b/testsuites/sptests/sp58/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp58
+sp58_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp58.scn
+dist_rtems_tests_DATA += sp58.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp58_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp58_OBJECTS) $(sp58_LDADD)
+LINK_LIBS = $(sp58_LDLIBS)
+
+sp58$(EXEEXT): $(sp58_OBJECTS) $(sp58_DEPENDENCIES)
+ @rm -f sp58$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am