summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp57/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-08 18:49:15 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-08 18:49:15 +0000
commit02819318cdd3516e1e2a625d26d532fda7eb8cd3 (patch)
tree6e41691c6123139990ec11eedd8cacb158baf3a0 /testsuites/sptests/sp57/Makefile.am
parent2009-07-08 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-02819318cdd3516e1e2a625d26d532fda7eb8cd3.tar.bz2
2009-07-08 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac: Add test of restarting a task which is in the middle of a sleep or wake after. * sp57/.cvsignore, sp57/Makefile.am, sp57/init.c, sp57/sp57.doc, sp57/sp57.scn: New files.
Diffstat (limited to 'testsuites/sptests/sp57/Makefile.am')
-rw-r--r--testsuites/sptests/sp57/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/testsuites/sptests/sp57/Makefile.am b/testsuites/sptests/sp57/Makefile.am
new file mode 100644
index 0000000000..e15340c96c
--- /dev/null
+++ b/testsuites/sptests/sp57/Makefile.am
@@ -0,0 +1,29 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp57
+sp57_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp57.scn
+dist_rtems_tests_DATA += sp57.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp57_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+AM_CPPFLAGS += -DUSE_TIMER_SERVER
+
+LINK_OBJS = $(sp57_OBJECTS) $(sp57_LDADD)
+LINK_LIBS = $(sp57_LDLIBS)
+
+sp57$(EXEEXT): $(sp57_OBJECTS) $(sp57_DEPENDENCIES)
+ @rm -f sp57$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am