summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp55/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-06 17:10:39 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-06 17:10:39 +0000
commit630a2a68ead5237cbbf0647bfd3af32437fb9348 (patch)
tree215044fa7985d9a64e5452b5b252ffefddb5bd60 /testsuites/sptests/sp55/Makefile.am
parent2009-07-06 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-630a2a68ead5237cbbf0647bfd3af32437fb9348.tar.bz2
2009-07-06 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac: Add new test to exercise case when broadcasting to a message queue with a pending message. * sp55/.cvsignore, sp55/Makefile.am, sp55/init.c, sp55/sp55.doc, sp55/sp55.scn: New files.
Diffstat (limited to 'testsuites/sptests/sp55/Makefile.am')
-rw-r--r--testsuites/sptests/sp55/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/testsuites/sptests/sp55/Makefile.am b/testsuites/sptests/sp55/Makefile.am
new file mode 100644
index 0000000000..16958d1920
--- /dev/null
+++ b/testsuites/sptests/sp55/Makefile.am
@@ -0,0 +1,29 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp55
+sp55_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp55.scn
+dist_rtems_tests_DATA += sp55.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp55_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+AM_CPPFLAGS += -DUSE_TIMER_SERVER
+
+LINK_OBJS = $(sp55_OBJECTS) $(sp55_LDADD)
+LINK_LIBS = $(sp55_LDLIBS)
+
+sp55$(EXEEXT): $(sp55_OBJECTS) $(sp55_DEPENDENCIES)
+ @rm -f sp55$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am