summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp54/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-06-10 17:09:34 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-06-10 17:09:34 +0000
commit293a0a41d23fc3406308794eaff051c4265b650e (patch)
tree572ae838f8c9786bb8d35328a60b4bda655e9ef0 /testsuites/sptests/sp54/Makefile.am
parent2009-06-10 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-293a0a41d23fc3406308794eaff051c4265b650e.tar.bz2
2009-06-10 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac: Add new test. * sp54/.cvsignore, sp54/Makefile.am, sp54/init.c, sp54/sp54.doc, sp54/sp54.scn: New files.
Diffstat (limited to 'testsuites/sptests/sp54/Makefile.am')
-rw-r--r--testsuites/sptests/sp54/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/testsuites/sptests/sp54/Makefile.am b/testsuites/sptests/sp54/Makefile.am
new file mode 100644
index 0000000000..e83d881a04
--- /dev/null
+++ b/testsuites/sptests/sp54/Makefile.am
@@ -0,0 +1,29 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp54
+sp54_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp54.scn
+dist_rtems_tests_DATA += sp54.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp54_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+AM_CPPFLAGS += -DUSE_TIMER_SERVER
+
+LINK_OBJS = $(sp54_OBJECTS) $(sp54_LDADD)
+LINK_LIBS = $(sp54_LDLIBS)
+
+sp54$(EXEEXT): $(sp54_OBJECTS) $(sp54_DEPENDENCIES)
+ @rm -f sp54$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am