summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp53/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-06-08 21:05:20 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-06-08 21:05:20 +0000
commit25686a5718867760da4575234a7cbf33fa41bd8d (patch)
tree64f40a2a9ce0964bc1cfb54407efdc1070c82eb5 /testsuites/sptests/sp53/Makefile.am
parent2009-06-06 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-25686a5718867760da4575234a7cbf33fa41bd8d.tar.bz2
2009-06-08 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac: Add sp52 and sp53 based upon bug report from Sergio Faustino <sergio.faustino@edisoft.pt> regarding moving the time of day forward not making server based timers fire. * sp52/.cvsignore, sp52/Makefile.am, sp52/init.c, sp52/sp52.doc, sp52/sp52.scn, sp53/.cvsignore, sp53/Makefile.am, sp53/sp53.doc, sp53/sp53.scn: New files.
Diffstat (limited to 'testsuites/sptests/sp53/Makefile.am')
-rw-r--r--testsuites/sptests/sp53/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/testsuites/sptests/sp53/Makefile.am b/testsuites/sptests/sp53/Makefile.am
new file mode 100644
index 0000000000..83861ced6f
--- /dev/null
+++ b/testsuites/sptests/sp53/Makefile.am
@@ -0,0 +1,29 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp53
+sp53_SOURCES = ../sp52/init.c
+
+dist_rtems_tests_DATA = sp53.scn
+dist_rtems_tests_DATA += sp53.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp53_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+AM_CPPFLAGS += -DUSE_TIMER_SERVER
+
+LINK_OBJS = $(sp53_OBJECTS) $(sp53_LDADD)
+LINK_LIBS = $(sp53_LDLIBS)
+
+sp53$(EXEEXT): $(sp53_OBJECTS) $(sp53_DEPENDENCIES)
+ @rm -f sp53$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am