summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp50/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-05-21 15:42:52 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-05-21 15:42:52 +0000
commit8abaa16177ea7de1e9862695285e09bc26e354f2 (patch)
tree1ebd1dbfe24afb3dc8551f7b4e668263c24e5509 /testsuites/sptests/sp50/Makefile.am
parent2009-05-21 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-8abaa16177ea7de1e9862695285e09bc26e354f2.tar.bz2
2009-05-21 Joel Sherrill <joel.sherrill@oarcorp.com>
PR 1413/cpukit * Makefile.am, configure.ac: Add test for case where server based timers which reinitiated themselves did not get reinserted onto timer chain. * sp50/.cvsignore, sp50/Makefile.am, sp50/init.c, sp50/sp50.doc, sp50/sp50.scn: New files.
Diffstat (limited to 'testsuites/sptests/sp50/Makefile.am')
-rw-r--r--testsuites/sptests/sp50/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/sptests/sp50/Makefile.am b/testsuites/sptests/sp50/Makefile.am
new file mode 100644
index 0000000000..dd244ba189
--- /dev/null
+++ b/testsuites/sptests/sp50/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp50
+sp50_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp50.scn
+dist_rtems_tests_DATA += sp50.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp50_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp50_OBJECTS) $(sp50_LDADD)
+LINK_LIBS = $(sp50_LDLIBS)
+
+sp50$(EXEEXT): $(sp50_OBJECTS) $(sp50_DEPENDENCIES)
+ @rm -f sp50$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am