summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp47/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-01-21 20:47:58 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-01-21 20:47:58 +0000
commit03f0885546cd067f01be23c611a2795b97ecacc0 (patch)
tree512808dd6f66f6268e0b5b3f203333dba30640f1 /testsuites/sptests/sp47/Makefile.am
parent2009-01-21 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-03f0885546cd067f01be23c611a2795b97ecacc0.tar.bz2
2009-01-21 Nickolay Kolchin <nbkolchin@gmail.com>
Joel Sherrill <joel.sherrill@oarcorp.com> PR 1357/cpukit * rtems/src/tasks.c: Ensure creating a task with no ASR is honored.
Diffstat (limited to 'testsuites/sptests/sp47/Makefile.am')
-rw-r--r--testsuites/sptests/sp47/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/sptests/sp47/Makefile.am b/testsuites/sptests/sp47/Makefile.am
new file mode 100644
index 0000000000..c0a1f04335
--- /dev/null
+++ b/testsuites/sptests/sp47/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp47.exe
+sp47_exe_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp47.scn
+dist_rtems_tests_DATA += sp47.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp47_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp47_exe_OBJECTS) $(sp47_exe_LDADD)
+LINK_LIBS = $(sp47_exe_LDLIBS)
+
+sp47.exe$(EXEEXT): $(sp47_exe_OBJECTS) $(sp47_exe_DEPENDENCIES)
+ @rm -f sp47.exe$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am