summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp45/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-12-03 20:59:49 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-12-03 20:59:49 +0000
commita88e2dd030d0c258abb7d2ba53efc13fa912d62c (patch)
tree9b8ff368d4bd5fe258ee72208a42ce2f97ee6daa /testsuites/sptests/sp45/Makefile.am
parent2008-12-03 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-a88e2dd030d0c258abb7d2ba53efc13fa912d62c.tar.bz2
2008-12-03 Joel Sherrill <joel.sherrill@OARcorp.com>
PR 1347/cpukit * Makefile.am, configure.ac, sp30/resume.c, sp30/task1.c, sp31/delay.c: Rework Timer Server to ensure that the context allows for blocking, allocating memory, and acquiring semaphores and mutexes. * sp45/.cvsignore, sp45/Makefile.am, sp45/sp45.doc, sp45/sp45.scn: New files.
Diffstat (limited to 'testsuites/sptests/sp45/Makefile.am')
-rw-r--r--testsuites/sptests/sp45/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/sptests/sp45/Makefile.am b/testsuites/sptests/sp45/Makefile.am
new file mode 100644
index 0000000000..a1618b3100
--- /dev/null
+++ b/testsuites/sptests/sp45/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp45.exe
+sp45_exe_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp45.scn
+dist_rtems_tests_DATA += sp45.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp45_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp45_exe_OBJECTS) $(sp45_exe_LDADD)
+LINK_LIBS = $(sp45_exe_LDLIBS)
+
+sp45.exe$(EXEEXT): $(sp45_exe_OBJECTS) $(sp45_exe_DEPENDENCIES)
+ @rm -f sp45.exe$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am