summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp35/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-03-05 21:01:53 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-03-05 21:01:53 +0000
commit88e8cc4d12c77a2818fa5558c7bff9df2765b66c (patch)
tree3977bf33a4fa6b1130f277c6add6c5e47b6bd028 /testsuites/sptests/sp35/Makefile.am
parent2007-03-05 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-88e8cc4d12c77a2818fa5558c7bff9df2765b66c.tar.bz2
2007-03-05 Joel Sherrill <joel@OARcorp.com>
PR 1222/cpukit * Makefile.am, configure.ac: Enhance so that when the prioirity of a thread that is blocked on a priority based thread queue is changed, that its placement in the queue is reevaluated based upon the new priority. This enhancement includes modifications to the SuperCore as well as new test cases. * sp34/.cvsignore, sp34/Makefile.am, sp34/changepri.c, sp34/sp34.doc, sp34/sp34.scn, sp35/.cvsignore, sp35/Makefile.am, sp35/priinv.c, sp35/sp35.doc, sp35/sp35.scn: New files.
Diffstat (limited to 'testsuites/sptests/sp35/Makefile.am')
-rw-r--r--testsuites/sptests/sp35/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/testsuites/sptests/sp35/Makefile.am b/testsuites/sptests/sp35/Makefile.am
new file mode 100644
index 0000000000..2d5b263509
--- /dev/null
+++ b/testsuites/sptests/sp35/Makefile.am
@@ -0,0 +1,24 @@
+##
+## $Id$
+##
+
+rtems_tests_PROGRAMS = sp35.exe
+sp35_exe_SOURCES = priinv.c
+
+dist_rtems_tests_DATA = sp35.scn
+dist_rtems_tests_DATA += sp35.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp35_exe_OBJECTS) $(sp35_exe_LDADD)
+LINK_LIBS = $(sp35_exe_LDLIBS)
+
+sp35.exe$(EXEEXT): $(sp35_exe_OBJECTS) $(sp35_exe_DEPENDENCIES)
+ @rm -f sp35.exe$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am