summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp18/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-30 00:15:59 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-30 00:15:59 +0000
commit8b40e27c0c5d827605c5e9e6a6f09cbb8449d578 (patch)
tree339359342a4d15c0f3ddc6ca67e7c2cf33e08e79 /testsuites/sptests/sp18/Makefile.am
parent2009-07-29 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-8b40e27c0c5d827605c5e9e6a6f09cbb8449d578.tar.bz2
2009-07-29 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac: Add new test to exercise as many cases as possible of not being able to allocate memory from the workspace during thread creation. * sp18/.cvsignore, sp18/Makefile.am, sp18/init.c, sp18/sp18.doc, sp18/sp18.scn: New files.
Diffstat (limited to 'testsuites/sptests/sp18/Makefile.am')
-rw-r--r--testsuites/sptests/sp18/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/sptests/sp18/Makefile.am b/testsuites/sptests/sp18/Makefile.am
new file mode 100644
index 0000000000..b4dff4ff5b
--- /dev/null
+++ b/testsuites/sptests/sp18/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp18
+sp18_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp18.scn
+dist_rtems_tests_DATA += sp18.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp18_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp18_OBJECTS) $(sp18_LDADD)
+LINK_LIBS = $(sp18_LDLIBS)
+
+sp18$(EXEEXT): $(sp18_OBJECTS) $(sp18_DEPENDENCIES)
+ @rm -f sp18$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am