summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/configure.ac
diff options
context:
space:
mode:
authorJennifer Averett <jennifer.averett@oarcorp.com>2013-12-16 13:13:14 -0600
committerJennifer Averett <jennifer.averett@oarcorp.com>2013-12-19 14:11:09 -0600
commitfe011a59a4b6fe2879f2c2354e8771c3f8aad6aa (patch)
treedb34e117b4d9add862dc35f3ec0707c8c15be909 /testsuites/sptests/configure.ac
parentcpukit/capture: Update the capture engine. (diff)
downloadrtems-fe011a59a4b6fe2879f2c2354e8771c3f8aad6aa.tar.bz2
sptests/spcpuset*: Add tests for fixed size cpu_set_t operations.
This adds five tests for <sys/cpuset.h>. It does not include tests for CPU_XXX_S methods. The autotools should be able to avoid enabling the tests unless the toolset has <sys/cpuset.h>.
Diffstat (limited to 'testsuites/sptests/configure.ac')
-rw-r--r--testsuites/sptests/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/testsuites/sptests/configure.ac b/testsuites/sptests/configure.ac
index 520be889c4..daf72cc8c2 100644
--- a/testsuites/sptests/configure.ac
+++ b/testsuites/sptests/configure.ac
@@ -25,6 +25,10 @@ RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
# FIXME: We should get rid of this. It's a cludge.
AC_CHECK_SIZEOF([time_t])
+# Added to newlib pthreads for RTEMS SMP (np), may not be present
+AC_CHECK_HEADERS([sys/cpuset.h])
+AM_CONDITIONAL(HAS_CPUSET,test x"${ac_cv_header_sys_cpuset_h}" = x"yes")
+
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile
spintrcritical20/Makefile
@@ -199,5 +203,6 @@ spwatchdog/Makefile
spwkspace/Makefile
sptimer_err01/Makefile
sptimer_err02/Makefile
+spcpuset01/Makefile
])
AC_OUTPUT