summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-09-14 20:05:44 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-09-14 20:05:44 +0000
commita5b04dabd923fcb3a9d1586d9ff01bdc81de83ba (patch)
tree7fa8a1d9c24a741cf28832d5f5cc005ba2ddc1ca /testsuites/sptests/configure.ac
parent2009-09-14 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-a5b04dabd923fcb3a9d1586d9ff01bdc81de83ba.tar.bz2
2009-09-14 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac, sp65/init.c: Add new test to exercise very simple priority ceiling case that was previously only tested via the POSIX API. * sp66/.cvsignore, sp66/Makefile.am, sp66/init.c, sp66/sp66.doc, sp66/sp66.scn: New files.
Diffstat (limited to 'testsuites/sptests/configure.ac')
-rw-r--r--testsuites/sptests/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/testsuites/sptests/configure.ac b/testsuites/sptests/configure.ac
index 9024150d73..fd00082f8b 100644
--- a/testsuites/sptests/configure.ac
+++ b/testsuites/sptests/configure.ac
@@ -23,6 +23,9 @@ RTEMS_CANONICALIZE_TOOLS
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_ENABLE_COVERAGE
+AM_CONDITIONAL([HAS_COVERAGE],[test $RTEMS_HAS_COVERAGE = "yes"])
+
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile
sp01/Makefile
@@ -91,6 +94,7 @@ sp62/Makefile
sp63/Makefile
sp64/Makefile
sp65/Makefile
+sp66/Makefile
spchain/Makefile
spclockget/Makefile
spcoverage/Makefile