summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2015-06-28 22:06:36 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2015-07-30 09:11:18 +0200
commit214d8edd1817adc96d529c9f9fe5646f9506d682 (patch)
treeeb31556faaa5d34b9457445055f93798ed09eba1 /testsuites/sptests/configure.ac
parentscore: Add thread queue for self-contained objects (diff)
downloadrtems-214d8edd1817adc96d529c9f9fe5646f9506d682.tar.bz2
score: Add self-contained mutex implementation
This mutex implementation uses a thread priority queue with a simple priority inheritance mechanism (similar to the object based mutexes). The storage space must be supplied by the user (16 bytes on 32-bit targets).
Diffstat (limited to 'testsuites/sptests/configure.ac')
-rw-r--r--testsuites/sptests/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/testsuites/sptests/configure.ac b/testsuites/sptests/configure.ac
index 99e9b892d7..be69f092b2 100644
--- a/testsuites/sptests/configure.ac
+++ b/testsuites/sptests/configure.ac
@@ -30,6 +30,9 @@ AM_CONDITIONAL([HAS_CPLUSPLUS],[test $HAS_CPLUSPLUS = "yes"])
# FIXME: We should get rid of this. It's a cludge.
AC_CHECK_SIZEOF([time_t])
+AC_CHECK_TYPES([struct _Thread_queue_Queue],[],[],[#include <sys/lock.h>])
+AM_CONDITIONAL(HAS__THREAD_QUEUE_QUEUE,test x"${ac_cv_type_struct__Thread_queue_Queue}" = x"yes")
+
# Added to newlib pthreads for RTEMS SMP (np), may not be present
AC_CHECK_HEADERS([sys/cpuset.h])
AM_CONDITIONAL(HAS_CPUSET,test x"${ac_cv_header_sys_cpuset_h}" = x"yes")
@@ -40,6 +43,7 @@ AM_CONDITIONAL(HAS_SMP,test "$rtems_cv_RTEMS_SMP" = "yes")
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile
+spsyslock01/Makefile
sptasknopreempt01/Makefile
spintrcritical23/Makefile
sptimecounter01/Makefile