summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/Makefile.am
diff options
context:
space:
mode:
authorJennifer Averett <jennifer.averett@oarcorp.com>2013-12-16 13:13:14 -0600
committerJennifer Averett <jennifer.averett@oarcorp.com>2013-12-19 14:11:09 -0600
commitfe011a59a4b6fe2879f2c2354e8771c3f8aad6aa (patch)
treedb34e117b4d9add862dc35f3ec0707c8c15be909 /testsuites/sptests/Makefile.am
parentcpukit/capture: Update the capture engine. (diff)
downloadrtems-fe011a59a4b6fe2879f2c2354e8771c3f8aad6aa.tar.bz2
sptests/spcpuset*: Add tests for fixed size cpu_set_t operations.
This adds five tests for <sys/cpuset.h>. It does not include tests for CPU_XXX_S methods. The autotools should be able to avoid enabling the tests unless the toolset has <sys/cpuset.h>.
Diffstat (limited to 'testsuites/sptests/Makefile.am')
-rw-r--r--testsuites/sptests/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/testsuites/sptests/Makefile.am b/testsuites/sptests/Makefile.am
index 118395b0b8..da707a97ef 100644
--- a/testsuites/sptests/Makefile.am
+++ b/testsuites/sptests/Makefile.am
@@ -39,5 +39,9 @@ SUBDIRS += spinternalerror01
SUBDIRS += spinternalerror02
SUBDIRS += sptimer_err01 sptimer_err02
+if HAS_CPUSET
+SUBDIRS += spcpuset01
+endif
+
include $(top_srcdir)/../automake/subdirs.am
include $(top_srcdir)/../automake/local.am