summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-05-14 13:50:48 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-05-15 12:18:44 +0200
commitf39f667a69cf5c4bc0dd4555537615022767f0f9 (patch)
treef8a48b3c7bf443001b036ddcab6ed104210e6134 /testsuites/sptests/Makefile.am
parentscore: Add and use _Scheduler_Get_context() (diff)
downloadrtems-f39f667a69cf5c4bc0dd4555537615022767f0f9.tar.bz2
score: Simplify _Thread_Change_priority()
The function to change a thread priority was too complex. Simplify it with a new scheduler operation. This increases the average case performance due to the simplified logic. The interrupt disabled critical section is a bit prolonged since now the extract, update and enqueue steps are executed atomically. This should however not impact the worst-case interrupt latency since at least for the Deterministic Priority Scheduler this sequence can be carried out with a wee bit of instructions and no loops. Add _Scheduler_Change_priority() to replace the sequence of - _Thread_Set_transient(), - _Scheduler_Extract(), - _Scheduler_Enqueue(), and - _Scheduler_Enqueue_first(). Delete STATES_TRANSIENT, _States_Is_transient() and _Thread_Set_transient() since this state is now superfluous. With this change it is possible to get rid of the SCHEDULER_SMP_NODE_IN_THE_AIR state. This considerably simplifies the implementation of the new SMP locking protocols.
Diffstat (limited to 'testsuites/sptests/Makefile.am')
-rw-r--r--testsuites/sptests/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/testsuites/sptests/Makefile.am b/testsuites/sptests/Makefile.am
index 999c7582f9..ef25b25568 100644
--- a/testsuites/sptests/Makefile.am
+++ b/testsuites/sptests/Makefile.am
@@ -50,7 +50,6 @@ _SUBDIRS += sptls02
endif
_SUBDIRS += sptls01
_SUBDIRS += spintrcritical20
-_SUBDIRS += spintrcritical19
_SUBDIRS += spcontext01
_SUBDIRS += spfatal26
_SUBDIRS += speventtransient01