summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-09-20 07:57:08 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-09-21 07:19:29 +0200
commit56e61e24bd8cada5b25f6d4fdf433eed84f25204 (patch)
treec7eadd8eb5af389c61aa730251cad8392d6290b9 /testsuites/sptests/Makefile.am
parentclang: Keep -qrtems and -B for compilers without -specs support (diff)
downloadrtems-56e61e24bd8cada5b25f6d4fdf433eed84f25204.tar.bz2
Remove INTERNAL_ERROR_INTERRUPT_STACK_TOO_SMALL
The configured interrupt stack size (CONFIGURE_INTERRUPT_STACK_SIZE) is checked against the minimum task stack size. The minium tasks task stack size is also a configuration option (CONFIGURE_MINIMUM_TASK_STACK_SIZE). So, this check does not really help in case of configuration errors. In addition, the interrupt stack is also re-used as the initialization stack in most BSPs. It is probably better to use a stack checker to detect problems. Update #3459.
Diffstat (limited to 'testsuites/sptests/Makefile.am')
-rw-r--r--testsuites/sptests/Makefile.am10
1 files changed, 0 insertions, 10 deletions
diff --git a/testsuites/sptests/Makefile.am b/testsuites/sptests/Makefile.am
index d9a6bf235e..7574dba39a 100644
--- a/testsuites/sptests/Makefile.am
+++ b/testsuites/sptests/Makefile.am
@@ -926,16 +926,6 @@ spfatal06_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal06) \
$(support_includes) -I$(top_srcdir)/spfatal06
endif
-if TEST_spfatal07
-sp_tests += spfatal07
-sp_screens += spfatal07/spfatal07.scn
-sp_docs += spfatal07/spfatal07.doc
-spfatal07_SOURCES = spfatal_support/init.c spfatal_support/system.h \
- spfatal07/testcase.h
-spfatal07_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal07) \
- $(support_includes) -I$(top_srcdir)/spfatal07
-endif
-
if TEST_spfatal08
sp_tests += spfatal08
sp_screens += spfatal08/spfatal08.scn