summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/smppsxaffinity01/Makefile.am
diff options
context:
space:
mode:
authorJennifer Averett <jennifer.averett@oarcorp.com>2014-02-26 09:41:04 -0600
committerJennifer Averett <jennifer.averett@oarcorp.com>2014-03-07 09:13:35 -0600
commitf3e6b18a4aa799d778ded7c952baeac6ae26ade0 (patch)
treeb1ab8ef558450080002b3fd46a21bd8c08df330b /testsuites/smptests/smppsxaffinity01/Makefile.am
parentsmptests: Add smpaffinity01 (diff)
downloadrtems-f3e6b18a4aa799d778ded7c952baeac6ae26ade0.tar.bz2
smptests: Add smppsxaffinity01.
This test exercises the ability to obtain and modify the affinity field of the POSIX thread attributes.
Diffstat (limited to 'testsuites/smptests/smppsxaffinity01/Makefile.am')
-rw-r--r--testsuites/smptests/smppsxaffinity01/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/testsuites/smptests/smppsxaffinity01/Makefile.am b/testsuites/smptests/smppsxaffinity01/Makefile.am
new file mode 100644
index 0000000000..1788923f73
--- /dev/null
+++ b/testsuites/smptests/smppsxaffinity01/Makefile.am
@@ -0,0 +1,23 @@
+
+rtems_tests_PROGRAMS = smppsxaffinity01
+smppsxaffinity01_SOURCES = init.c
+
+dist_rtems_tests_DATA = smppsxaffinity01.scn
+dist_rtems_tests_DATA += smppsxaffinity01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(smppsxaffinity01_OBJECTS)
+LINK_LIBS = $(smppsxaffinity01_LDLIBS)
+
+smppsxaffinity01$(EXEEXT): $(smppsxaffinity01_OBJECTS) $(smppsxaffinity01_DEPENDENCIES)
+ @rm -f smppsxaffinity01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am