summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/smpfatal06/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-04-09 15:07:54 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-04-15 10:41:44 +0200
commitc5831a3f9af11228dbdaabaf01f69d37e55684ef (patch)
treee9ddedd942f3f31d239820dfc4dbcef4cde0b09a /testsuites/smptests/smpfatal06/Makefile.am
parentrtems: Add task get/set scheduler (diff)
downloadrtems-c5831a3f9af11228dbdaabaf01f69d37e55684ef.tar.bz2
score: Add clustered/partitioned scheduling
Clustered/partitioned scheduling helps to control the worst-case latencies in the system. The goal is to reduce the amount of shared state in the system and thus prevention of lock contention. Modern multi-processor systems tend to have several layers of data and instruction caches. With clustered/partitioned scheduling it is possible to honour the cache topology of a system and thus avoid expensive cache synchronization traffic. We have clustered scheduling in case the set of processors of a system is partitioned into non-empty pairwise-disjoint subsets. These subsets are called clusters. Clusters with a cardinality of one are partitions. Each cluster is owned by exactly one scheduler instance.
Diffstat (limited to 'testsuites/smptests/smpfatal06/Makefile.am')
-rw-r--r--testsuites/smptests/smpfatal06/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/testsuites/smptests/smpfatal06/Makefile.am b/testsuites/smptests/smpfatal06/Makefile.am
new file mode 100644
index 0000000000..c0bdf5bb23
--- /dev/null
+++ b/testsuites/smptests/smpfatal06/Makefile.am
@@ -0,0 +1,19 @@
+rtems_tests_PROGRAMS = smpfatal06
+smpfatal06_SOURCES = init.c
+
+dist_rtems_tests_DATA = smpfatal06.scn smpfatal06.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(smpfatal06_OBJECTS)
+LINK_LIBS = $(smpfatal06_LDLIBS)
+
+smpfatal06$(EXEEXT): $(smpfatal06_OBJECTS) $(smpfatal06_DEPENDENCIES)
+ @rm -f smpfatal06$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am