summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/smpcapture02/Makefile.am
diff options
context:
space:
mode:
authorDaniel Cederman <cederman@gaisler.com>2015-02-04 10:04:05 +0100
committerDaniel Hellstrom <daniel@gaisler.com>2015-02-11 15:35:26 +0100
commit8d8573acc8f620c93afa8dd30ea8418d25ad2d21 (patch)
tree41051541bd765a98f16d8e996fdf2f1742d91c03 /testsuites/smptests/smpcapture02/Makefile.am
parentbsp/sparc: Move BSP_ISR_handler to a separate file and rename it (diff)
downloadrtems-8d8573acc8f620c93afa8dd30ea8418d25ad2d21.tar.bz2
smpcapture02: Add test of functionality to add custom entries to capture trace
Diffstat (limited to 'testsuites/smptests/smpcapture02/Makefile.am')
-rw-r--r--testsuites/smptests/smpcapture02/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/testsuites/smptests/smpcapture02/Makefile.am b/testsuites/smptests/smpcapture02/Makefile.am
new file mode 100644
index 0000000000..d7a172ced7
--- /dev/null
+++ b/testsuites/smptests/smpcapture02/Makefile.am
@@ -0,0 +1,19 @@
+rtems_tests_PROGRAMS = smpcapture02
+smpcapture02_SOURCES = init.c
+
+dist_rtems_tests_DATA = smpcapture02.scn smpcapture02.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(smpcapture02_OBJECTS)
+LINK_LIBS = $(smpcapture02_LDLIBS)
+
+smpcapture02$(EXEEXT): $(smpcapture02_OBJECTS) $(smpcapture02_DEPENDENCIES)
+ @rm -f smpcapture02$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am