summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-04-09 15:07:54 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-04-15 10:41:44 +0200
commitc5831a3f9af11228dbdaabaf01f69d37e55684ef (patch)
treee9ddedd942f3f31d239820dfc4dbcef4cde0b09a /testsuites/smptests/configure.ac
parentrtems: Add task get/set scheduler (diff)
downloadrtems-c5831a3f9af11228dbdaabaf01f69d37e55684ef.tar.bz2
score: Add clustered/partitioned scheduling
Clustered/partitioned scheduling helps to control the worst-case latencies in the system. The goal is to reduce the amount of shared state in the system and thus prevention of lock contention. Modern multi-processor systems tend to have several layers of data and instruction caches. With clustered/partitioned scheduling it is possible to honour the cache topology of a system and thus avoid expensive cache synchronization traffic. We have clustered scheduling in case the set of processors of a system is partitioned into non-empty pairwise-disjoint subsets. These subsets are called clusters. Clusters with a cardinality of one are partitions. Each cluster is owned by exactly one scheduler instance.
Diffstat (limited to 'testsuites/smptests/configure.ac')
-rw-r--r--testsuites/smptests/configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/testsuites/smptests/configure.ac b/testsuites/smptests/configure.ac
index 97b825bccc..ee36b50568 100644
--- a/testsuites/smptests/configure.ac
+++ b/testsuites/smptests/configure.ac
@@ -57,7 +57,6 @@ AM_CONDITIONAL(HAS_CPUSET,test x"${ac_cv_header_sys_cpuset_h}" = x"yes")
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile
-smpload01/Makefile
smp01/Makefile
smp02/Makefile
smp03/Makefile
@@ -70,12 +69,19 @@ smpatomic01/Makefile
smpfatal01/Makefile
smpfatal02/Makefile
smpfatal03/Makefile
+smpfatal04/Makefile
+smpfatal05/Makefile
+smpfatal06/Makefile
+smpfatal07/Makefile
+smpfatal08/Makefile
+smpload01/Makefile
smplock01/Makefile
smpmigration01/Makefile
smppsxaffinity01/Makefile
smppsxaffinity02/Makefile
smppsxsignal01/Makefile
smpscheduler01/Makefile
+smpscheduler02/Makefile
smpsignal01/Makefile
smpswitchextension01/Makefile
smpthreadlife01/Makefile