summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-12-18 08:45:06 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-12-18 08:50:08 +0100
commit7c19e50bdd3b6ae234b171992f2e109d4f804cda (patch)
treec967305bf67491cb855cf19077139ad836113d8e /testsuites/smptests/configure.ac
parentconfig: Remove CONFIGURE_CONFDEFS_DEBUG (diff)
downloadrtems-7c19e50bdd3b6ae234b171992f2e109d4f804cda.tar.bz2
score: Fix per-CPU data allocation
Allocate the per-CPU data for secondary processors directly from the heap areas before heap initialization and not via _Workspace_Allocate_aligned(). This avoids dependency on the workspace allocator. It fixes also a problem on some platforms (e.g. QorIQ) where at this early point in the system initialization the top of the RAM is used by low-level startup code on secondary processors (boot pages). Update #3507.
Diffstat (limited to 'testsuites/smptests/configure.ac')
-rw-r--r--testsuites/smptests/configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/testsuites/smptests/configure.ac b/testsuites/smptests/configure.ac
index 9c5b5e0031..b3fca201b2 100644
--- a/testsuites/smptests/configure.ac
+++ b/testsuites/smptests/configure.ac
@@ -53,6 +53,7 @@ RTEMS_TEST_CHECK([smpfatal04])
RTEMS_TEST_CHECK([smpfatal05])
RTEMS_TEST_CHECK([smpfatal06])
RTEMS_TEST_CHECK([smpfatal08])
+RTEMS_TEST_CHECK([smpfatal09])
RTEMS_TEST_CHECK([smpipi01])
RTEMS_TEST_CHECK([smpload01])
RTEMS_TEST_CHECK([smplock01])