summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-05-23 15:32:32 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-05-26 08:56:44 +0200
commitd134adeba3abd0fef8ed2046cc5bf7f877d7a77c (patch)
tree4ad0cb5a60e30d196c21654213b953685ca5d3ce /testsuites/smptests/Makefile.am
parentbsp/gdbarmsim: Change syscall functions to not clash with RTEMS functions. (diff)
downloadrtems-d134adeba3abd0fef8ed2046cc5bf7f877d7a77c.tar.bz2
score: Fix race condition in SMP startup
Do not use the Per_CPU_Control::started in _SMP_Start_multitasking_on_secondary_processor() since this field may be not up to date when a secondary processor reads it. Use the read-only scheduler assignment instead. Add a new fatal error SMP_FATAL_MULTITASKING_START_ON_INVALID_PROCESSOR. This prevents out-of-bounds access. It is currently not possible to test these fatal errors. One option would be to fake values of the _CPU_SMP_Get_current_processor(), but unfortunately this function is inline on some architectures.
Diffstat (limited to 'testsuites/smptests/Makefile.am')
-rw-r--r--testsuites/smptests/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/testsuites/smptests/Makefile.am b/testsuites/smptests/Makefile.am
index ed6fefdfe1..4a5a78b586 100644
--- a/testsuites/smptests/Makefile.am
+++ b/testsuites/smptests/Makefile.am
@@ -16,7 +16,6 @@ SUBDIRS += smpfatal02
SUBDIRS += smpfatal03
SUBDIRS += smpfatal04
SUBDIRS += smpfatal05
-SUBDIRS += smpfatal07
SUBDIRS += smpfatal08
SUBDIRS += smpipi01
SUBDIRS += smpload01