summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-05-15 10:31:22 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-05-15 12:18:49 +0200
commitc0bff5e936c4b967fe490e1e11eda00c638a8f6a (patch)
tree20de9081d713ebcc285ed0c592a38be6782fc3d3 /testsuites/smptests/Makefile.am
parentscore: Make _Thread_queue_Requeue() static (diff)
downloadrtems-c0bff5e936c4b967fe490e1e11eda00c638a8f6a.tar.bz2
score: Split SMP scheduler enqueue function
Extract code from _Scheduler_SMP_Enqueue_ordered() and move it to the new function _Scheduler_SMP_Enqueue_scheduled_ordered() to avoid untestable execution paths. Add and use function _Scheduler_SMP_Unblock().
Diffstat (limited to 'testsuites/smptests/Makefile.am')
-rw-r--r--testsuites/smptests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/testsuites/smptests/Makefile.am b/testsuites/smptests/Makefile.am
index 36fb156f3f..ed6fefdfe1 100644
--- a/testsuites/smptests/Makefile.am
+++ b/testsuites/smptests/Makefile.am
@@ -25,6 +25,7 @@ SUBDIRS += smpmigration01
SUBDIRS += smpmigration02
SUBDIRS += smpscheduler01
SUBDIRS += smpscheduler02
+SUBDIRS += smpscheduler03
SUBDIRS += smpsignal01
SUBDIRS += smpswitchextension01
SUBDIRS += smpthreadlife01