summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2016-11-10 12:02:28 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2016-11-23 12:52:06 +0100
commit84e6f15c828869eb7d293096cfcfa0563b5752b3 (patch)
treeefafb1ab17f6d1a612f79b6ec8d821ad9123756c /testsuites/smptests/Makefile.am
parentsmptests/smplock01: Test TAS and TTAS locks (diff)
downloadrtems-84e6f15c828869eb7d293096cfcfa0563b5752b3.tar.bz2
score: Robust thread dispatch
On SMP configurations, it is a fatal error to call blocking operating system with interrupts disabled, since this prevents delivery of inter-processor interrupts. This could lead to executing threads which are not allowed to execute resulting in undefined behaviour. The ARM Cortex-M port has a similar problem, since the interrupt state is not a part of the thread context. Update #2811.
Diffstat (limited to 'testsuites/smptests/Makefile.am')
-rw-r--r--testsuites/smptests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/testsuites/smptests/Makefile.am b/testsuites/smptests/Makefile.am
index 86b9fed1db..ba5b35f973 100644
--- a/testsuites/smptests/Makefile.am
+++ b/testsuites/smptests/Makefile.am
@@ -20,6 +20,7 @@ SUBDIRS += smpfatal02
SUBDIRS += smpfatal03
SUBDIRS += smpfatal04
SUBDIRS += smpfatal05
+SUBDIRS += smpfatal06
SUBDIRS += smpfatal08
SUBDIRS += smpipi01
SUBDIRS += smpload01