summaryrefslogtreecommitdiffstats
path: root/testsuites/smptests/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-12-18 08:45:06 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-12-18 08:50:08 +0100
commit7c19e50bdd3b6ae234b171992f2e109d4f804cda (patch)
treec967305bf67491cb855cf19077139ad836113d8e /testsuites/smptests/Makefile.am
parentconfig: Remove CONFIGURE_CONFDEFS_DEBUG (diff)
downloadrtems-7c19e50bdd3b6ae234b171992f2e109d4f804cda.tar.bz2
score: Fix per-CPU data allocation
Allocate the per-CPU data for secondary processors directly from the heap areas before heap initialization and not via _Workspace_Allocate_aligned(). This avoids dependency on the workspace allocator. It fixes also a problem on some platforms (e.g. QorIQ) where at this early point in the system initialization the top of the RAM is used by low-level startup code on secondary processors (boot pages). Update #3507.
Diffstat (limited to 'testsuites/smptests/Makefile.am')
-rw-r--r--testsuites/smptests/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/testsuites/smptests/Makefile.am b/testsuites/smptests/Makefile.am
index 2e8e5b1782..b5c2803d02 100644
--- a/testsuites/smptests/Makefile.am
+++ b/testsuites/smptests/Makefile.am
@@ -238,6 +238,17 @@ endif
endif
if HAS_SMP
+if TEST_smpfatal09
+smp_tests += smpfatal09
+smp_screens += smpfatal09/smpfatal09.scn
+smp_docs += smpfatal09/smpfatal09.doc
+smpfatal09_SOURCES = smpfatal09/init.c
+smpfatal09_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_smpfatal09) \
+ $(support_includes)
+endif
+endif
+
+if HAS_SMP
if TEST_smpipi01
smp_tests += smpipi01
smp_screens += smpipi01/smpipi01.scn