summaryrefslogtreecommitdiffstats
path: root/testsuites/samples/loopback/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2003-01-27 23:30:53 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2003-01-27 23:30:53 +0000
commit25b957c10a1126a59a53c4c7c3e319aaa6a4c9f4 (patch)
tree998a094b8653697d561934477af632270d8769a0 /testsuites/samples/loopback/Makefile.am
parent2003-01-27 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-25b957c10a1126a59a53c4c7c3e319aaa6a4c9f4.tar.bz2
2003-01-27 Joel Sherrill <joel@OARcorp.com>
* Makefile.am, configure.ac: Added new test loopback which shows how to use the loopback interface. Thank you Eric Norum for a portable target independent test which exercises the TCP/IP. This should prevent massive failures in the TCP/IP stack from reaching the street. * loopback/.cvsignore, loopback/Makefile.am, loopback/README, loopback/init.c, loopback/loopback.scn: New files.
Diffstat (limited to 'testsuites/samples/loopback/Makefile.am')
-rw-r--r--testsuites/samples/loopback/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/testsuites/samples/loopback/Makefile.am b/testsuites/samples/loopback/Makefile.am
new file mode 100644
index 0000000000..ef34244254
--- /dev/null
+++ b/testsuites/samples/loopback/Makefile.am
@@ -0,0 +1,41 @@
+##
+## $Id$
+##
+
+
+SAMPLE = loopback
+PGM = ${ARCH}/$(SAMPLE).exe
+
+MANAGERS = io event
+
+C_FILES = init.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
+
+DOCTYPES = scn
+DOCS = $(DOCTYPES:%=$(SAMPLE).%)
+
+SRCS = $(DOCS) $(C_FILES) $(H_FILES)
+OBJS = $(C_O_FILES)
+
+PRINT_SRCS = $(DOCS)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../../../automake/leaf.am
+include $(top_srcdir)/sample.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+
+if HAS_NETWORKING
+all-local: ${ARCH} $(TMPINSTALL_FILES)
+
+${PGM}: $(OBJS) $(LINK_FILES)
+ $(make-exe)
+endif
+
+EXTRA_DIST = $(C_FILES) $(DOCS)
+
+include $(top_srcdir)/../../../../automake/local.am