summaryrefslogtreecommitdiffstats
path: root/testsuites/samples/iostream/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-05-10 15:59:59 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-05-10 15:59:59 +0000
commite12ba0e4f07e5fda4219541ea7afdf6aa4833238 (patch)
tree81d086888f23bd3509dff8ead280d88a6908cd40 /testsuites/samples/iostream/Makefile.am
parent2004-05-10 Ralf Corsepius <ralf_corsepius@rtems.org> (diff)
downloadrtems-e12ba0e4f07e5fda4219541ea7afdf6aa4833238.tar.bz2
2004-05-10 Ralf Corsepius <ralf_corsepius@rtems.org>
* iostream/Makefile.am, iostream/init.cc, iostream/iostream.doc, iostream/iostream.scn, iostream/system.h: New (C++ variant of hello).
Diffstat (limited to 'testsuites/samples/iostream/Makefile.am')
-rw-r--r--testsuites/samples/iostream/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/testsuites/samples/iostream/Makefile.am b/testsuites/samples/iostream/Makefile.am
new file mode 100644
index 0000000000..333b4b648e
--- /dev/null
+++ b/testsuites/samples/iostream/Makefile.am
@@ -0,0 +1,42 @@
+##
+## $Id$
+##
+
+SAMPLE = iostream
+PGM = ${ARCH}/$(SAMPLE).exe
+
+MANAGERS = io
+
+CC_FILES = init.cc
+CC_O_FILES = $(CC_FILES:%.cc=${ARCH}/%.$(OBJEXT))
+
+H_FILES = system.h
+noinst_HEADERS = $(H_FILES)
+
+DOCTYPES = doc scn
+DOCS = $(DOCTYPES:%=$(SAMPLE).%)
+
+SRCS = $(DOCS) $(CC_FILES) $(H_FILES)
+OBJS = $(CC_O_FILES)
+
+PRINT_SRCS = $(DOCS)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+include $(top_srcdir)/sample.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+all-local: $(TMPINSTALL_FILES)
+
+${PGM}: $(OBJS) $(LINK_FILES)
+ $(make-cxx-exe)
+
+EXTRA_DIST = $(C_FILES) $(DOCS)
+
+CLEANFILES = $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../automake/local.am