summaryrefslogtreecommitdiffstats
path: root/testsuites/samples/configure.ac
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2018-04-09 13:44:01 +1000
committerChris Johns <chrisj@rtems.org>2018-04-10 08:24:54 +1000
commitd027e6bb8e2595d38736763c55f0cd46a3f3cd1e (patch)
tree01cd15c520f99b5686ace5a5fe393976f0a1d475 /testsuites/samples/configure.ac
parenttestsuite/irhealstone: Merged nested Makefile.am files into one Makefile.am (diff)
downloadrtems-d027e6bb8e2595d38736763c55f0cd46a3f3cd1e.tar.bz2
testsuite/samples: Merged nested Makefile.am files into one Makefile.am
This change is part of the testsuite Makefile.am reorganization. Update #3382
Diffstat (limited to 'testsuites/samples/configure.ac')
-rw-r--r--testsuites/samples/configure.ac39
1 files changed, 19 insertions, 20 deletions
diff --git a/testsuites/samples/configure.ac b/testsuites/samples/configure.ac
index 88e868feaf..dab65b0086 100644
--- a/testsuites/samples/configure.ac
+++ b/testsuites/samples/configure.ac
@@ -54,29 +54,28 @@ AS_IF([test $HAS_CPLUSPLUS = yes],[
AM_CONDITIONAL([CXXTESTS],[test $CXXTESTS = "yes"])
AM_CONDITIONAL(NETTESTS,test "$rtems_cv_RTEMS_NETWORKING" = "yes")
-AM_CONDITIONAL(MPTESTS,test "$rtems_cv_RTEMS_MULTIPROCESSING" = "yes")
+AM_CONDITIONAL(HAS_MP,test "$rtems_cv_RTEMS_MULTIPROCESSING" = "yes")
+AM_CONDITIONAL(NO_SMP,test "$rtems_cv_RTEMS_SMP" != "yes")
AM_CONDITIONAL(HAS_SMP,test "$rtems_cv_RTEMS_SMP" = "yes")
# FIXME: We should get rid of this. It's a cludge.
AC_CHECK_SIZEOF([time_t])
-# Explicitly list all Makefiles here
-AC_CONFIG_FILES([Makefile
-base_mp/Makefile
-base_mp/node1/Makefile
-base_mp/node2/Makefile
-base_sp/Makefile
-capture/Makefile
-cdtest/Makefile
-fileio/Makefile
-hello/Makefile
-iostream/Makefile
-loopback/Makefile
-minimum/Makefile
-nsecs/Makefile
-paranoia/Makefile
-pppd/Makefile
-ticker/Makefile
-unlimited/Makefile
-])
+# BSP Test configuration
+RTEMS_TEST_CHECK([base_mp])
+RTEMS_TEST_CHECK([base_sp])
+RTEMS_TEST_CHECK([capture])
+RTEMS_TEST_CHECK([cdtest])
+RTEMS_TEST_CHECK([iostream])
+RTEMS_TEST_CHECK([fileio])
+RTEMS_TEST_CHECK([hello])
+RTEMS_TEST_CHECK([loopback])
+RTEMS_TEST_CHECK([minimum])
+RTEMS_TEST_CHECK([nsecs])
+RTEMS_TEST_CHECK([paranoia])
+RTEMS_TEST_CHECK([pppd])
+RTEMS_TEST_CHECK([ticker])
+RTEMS_TEST_CHECK([unlimited])
+
+AC_CONFIG_FILES([Makefile])
AC_OUTPUT