summaryrefslogtreecommitdiffstats
path: root/testsuites/samples/capture/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2007-08-17 01:07:10 +0000
committerChris Johns <chrisj@rtems.org>2007-08-17 01:07:10 +0000
commit8db468ffde833523535720e8ec8119d760a9561a (patch)
tree11ac560f17473229c34809cbb8a2e737157f8372 /testsuites/samples/capture/Makefile.am
parent2007-08-17 Chris Johns <chrisj@rtems.org> (diff)
downloadrtems-8db468ffde833523535720e8ec8119d760a9561a.tar.bz2
2007-08-17 Chris Johns <chrisj@rtems.org>
* Makefile.am, README, configure.ac, capture/.cvsignore, capture/Makefile.am, capture/capture.doc, capture/capture.scn, capture/init.c, capture/system.h, capture/test1.c: Add a sample test for the capture engine.
Diffstat (limited to 'testsuites/samples/capture/Makefile.am')
-rw-r--r--testsuites/samples/capture/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/testsuites/samples/capture/Makefile.am b/testsuites/samples/capture/Makefile.am
new file mode 100644
index 0000000000..6a22fbafa2
--- /dev/null
+++ b/testsuites/samples/capture/Makefile.am
@@ -0,0 +1,26 @@
+##
+## $Id$
+##
+
+MANAGERS = io event
+
+rtems_tests_PROGRAMS = capture.exe
+capture_exe_SOURCES = init.c test1.c system.h
+
+dist_rtems_tests_DATA = capture.scn
+dist_rtems_tests_DATA += capture.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+unlimited_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+LINK_OBJS = $(capture_exe_OBJECTS) $(capture_exe_LDADD)
+LINK_LIBS = $(capture_exe_LDLIBS)
+
+capture.exe$(EXEEXT): $(capture_exe_OBJECTS) $(capture_exe_DEPENDENCIES)
+ @rm -f capture.exe$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am