summaryrefslogtreecommitdiffstats
path: root/testsuites/samples/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-22 19:21:38 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-22 19:21:38 +0000
commite31c63e5a8bae5fbda548f4b65c423b0fc2ce58c (patch)
treedb00eb2694d7dfd151e4c5f21b47a32e91e075ab /testsuites/samples/Makefile.am
parentConverted to automake. (diff)
downloadrtems-e31c63e5a8bae5fbda548f4b65c423b0fc2ce58c.tar.bz2
Patch rtems-rc-19991117-7.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
to convert the sample tests to automake.
Diffstat (limited to 'testsuites/samples/Makefile.am')
-rw-r--r--testsuites/samples/Makefile.am15
1 files changed, 6 insertions, 9 deletions
diff --git a/testsuites/samples/Makefile.am b/testsuites/samples/Makefile.am
index b04c376dd6..e8c84121ac 100644
--- a/testsuites/samples/Makefile.am
+++ b/testsuites/samples/Makefile.am
@@ -5,14 +5,6 @@
AUTOMAKE_OPTIONS = foreign 1.4
ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
-project_bspdir=$(PROJECT_ROOT)/@RTEMS_BSP@
-
-PREINSTALLDIRS = $(project_bspdir)/samples $(project_bspdir)/tests
-$(PREINSTALLDIRS):
- @$(mkinstalldirs) $@
-
-all-local: $(PREINSTALLDIRS)
-
CPLUSPLUS_TESTS = cdtest
## base_mp is a sample multiprocessing test
@@ -20,8 +12,13 @@ MP_TESTS = base_mp
FP_TESTS = paranoia
-SUBDIRS = . hello ticker base_sp unlimited minimum $(MP_TESTS) \
+SUBDIRS = hello ticker base_sp unlimited minimum $(MP_TESTS) \
$(CPLUSPLUS_TESTS) $(FP_TESTS)
+AUTOMAKE_FILES = \
+sample.am
+
+EXTRA_DIST = $(AUTOMAKE_FILES)
+
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am