summaryrefslogtreecommitdiffstats
path: root/testsuites/samples/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2017-04-04 08:11:24 +1000
committerChris Johns <chrisj@rtems.org>2017-04-04 08:24:22 +1000
commit258bda306ba25741624488d24a2785c055a9fab0 (patch)
tree66301d9e50cf6dbc08539b441cab8b41ffe2f895 /testsuites/samples/Makefile.am
parentbsp/qoriq: Fix L1 cache flush (diff)
downloadrtems-258bda306ba25741624488d24a2785c055a9fab0.tar.bz2
testsuite: Add a common test configuration. Fix configure.ac and Makefile.am errors.
- Add a top level test configuration file for test states that are common to all BSPs. This saves adding a test configuration (tcfg) file for every BSP. - Add the test states 'user-input' and 'benchmark'. This lets 'rtems-test' stop the test rather than waiting for a timeout or letting a benchmark run without the user asking for it to run. - Implement rtems-test-check in Python to make it faster. The shell script had grown to a point it was noticably slowing the build down. - Fix the configure.ac and Makefile.am files for a number of the test directories. The files are difficiult to keep in sync with the number of tests and mistakes can happen such as tests being left out of the build. The test fsrofs01 is an example. Also a there was a mix of SUBDIRS and _SUBDIRS being used and only _SUBDIRS should be used. - Fix the test fsrofs01 so it compiles. Closes #2963.
Diffstat (limited to 'testsuites/samples/Makefile.am')
-rw-r--r--testsuites/samples/Makefile.am20
1 files changed, 13 insertions, 7 deletions
diff --git a/testsuites/samples/Makefile.am b/testsuites/samples/Makefile.am
index 374617b7e4..85e89a50af 100644
--- a/testsuites/samples/Makefile.am
+++ b/testsuites/samples/Makefile.am
@@ -1,18 +1,24 @@
ACLOCAL_AMFLAGS = -I ../aclocal
-_SUBDIRS = hello capture ticker base_sp unlimited minimum fileio
+_SUBDIRS =
+_SUBDIRS += base_sp
+_SUBDIRS += capture
+_SUBDIRS += fileio
+_SUBDIRS += hello
+_SUBDIRS += minimum
+_SUBDIRS += nsecs
+_SUBDIRS += paranoia
+_SUBDIRS += ticker
+_SUBDIRS += unlimited
if MPTESTS
## base_mp is a sample multiprocessing test
_SUBDIRS += base_mp
endif
-_SUBDIRS += paranoia
-
-_SUBDIRS += nsecs
-
if CXXTESTS
-_SUBDIRS += iostream cdtest
+_SUBDIRS += cdtest
+_SUBDIRS += iostream
endif
if NETTESTS
@@ -24,5 +30,5 @@ _SUBDIRS += pppd
endif
endif
-include $(top_srcdir)/../automake/test-subdirs.am
+include $(top_srcdir)/../automake/subdirs.am
include $(top_srcdir)/../automake/local.am