summaryrefslogtreecommitdiffstats
path: root/testsuites/rhealstone/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2021-04-26 14:00:41 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2021-09-21 07:39:09 +0200
commitdb8f598d56951cf43f22a5e325e0d23c8f7559f9 (patch)
tree607bc2e2c842bb932bce53efc7423e73ef18f6ff /testsuites/rhealstone/Makefile.am
parentarm/lpc24xx: Use common test definition file (diff)
downloadrtems-db8f598d56951cf43f22a5e325e0d23c8f7559f9.tar.bz2
build: Remove old build system
Close #3250. Close #4081.
Diffstat (limited to 'testsuites/rhealstone/Makefile.am')
-rw-r--r--testsuites/rhealstone/Makefile.am70
1 files changed, 0 insertions, 70 deletions
diff --git a/testsuites/rhealstone/Makefile.am b/testsuites/rhealstone/Makefile.am
deleted file mode 100644
index bb214357fc..0000000000
--- a/testsuites/rhealstone/Makefile.am
+++ /dev/null
@@ -1,70 +0,0 @@
-#
-# Real-time Benchmarking
-#
-
-ACLOCAL_AMFLAGS = -I ../aclocal
-
-include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../automake/compile.am
-
-rhealstones =
-rhealstone_screens =
-rhealstone_docs =
-
-support_includes = -I$(top_srcdir)/../support/include
-
-if TEST_rhdeadlockbrk
-rhealstones += rhdeadlockbrk
-rhealstone_docs += rhdeadlockbrk/rhdeadlockbrk.adoc
-rhdeadlockbrk_SOURCES = rhdeadlockbrk/deadlockbrk.c \
- ../tmtests/include/timesys.h
-rhdeadlockbrk_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_rhdeadlockbrk) \
- $(support_includes) -I$(top_srcdir)/../tmtests/include
-endif
-
-if TEST_rhilatency
-rhealstones += rhilatency
-rhealstone_docs += rhilatency/rhilatency.adoc
-rhilatency_SOURCES = rhilatency/ilatency.c \
- ../tmtests/include/timesys.h
-rhilatency_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_rhilatency) \
- $(support_includes) -I$(top_srcdir)/../tmtests/include
-endif
-
-if TEST_rhmlatency
-rhealstones += rhmlatency
-rhealstone_docs += rhmlatency/rhmlatency.adoc
-rhmlatency_SOURCES = rhmlatency/mlatency.c \
- ../tmtests/include/timesys.h
-rhmlatency_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_rhmlatency) \
- $(support_includes) -I$(top_srcdir)/../tmtests/include
-endif
-
-if TEST_rhsemshuffle
-rhealstones += rhsemshuffle
-rhealstone_docs += rhsemshuffle/rhsemshuffle.adoc
-rhsemshuffle_SOURCES = rhsemshuffle/semshuffle.c \
- ../tmtests/include/timesys.h
-rhsemshuffle_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_rhsemshuffle) \
- $(support_includes) -I$(top_srcdir)/../tmtests/include
-endif
-
-if TEST_rhtaskpreempt
-rhealstones += rhtaskpreempt
-rhealstone_docs += rhtaskpreempt/rhtaskpreempt.adoc
-rhtaskpreempt_SOURCES = rhtaskpreempt/taskpreempt.c \
- ../tmtests/include/timesys.h
-rhtaskpreempt_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_rhtaskpreempt) \
- $(support_includes) -I$(top_srcdir)/../tmtests/include
-endif
-
-if TEST_rhtaskswitch
-rhealstones += rhtaskswitch
-rhealstone_docs += rhtaskswitch/rhtaskswitch.adoc
-rhtaskswitch_SOURCES = rhtaskswitch/taskswitch.c \
- ../tmtests/include/timesys.h
-rhtaskswitch_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_rhtaskswitch) \
- $(support_includes) -I$(top_srcdir)/../tmtests/include
-endif
-
-noinst_PROGRAMS = $(rhealstones)