summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtmtests/psxtmthread05/Makefile.am
diff options
context:
space:
mode:
authorChirayu Desai <cdesai@cyanogenmod.org>2013-11-24 12:34:13 +0530
committerGedare Bloom <gedare@rtems.org>2013-11-27 09:54:57 -0500
commitdb08c3897f86f99d5a4259506d4463b0ec440762 (patch)
treea87ec249ed33a7c8e074bd7443a9ffd2dd46280b /testsuites/psxtmtests/psxtmthread05/Makefile.am
parentraspberrypi doxygen refactoring (diff)
downloadrtems-db08c3897f86f99d5a4259506d4463b0ec440762.tar.bz2
psxtmtests: Add psxtmthread05 for pthread_setschedparam
New test psxtmthread 05 uses two tasks and times lowering the priority of one task plus the preemption and context switch to the other task.
Diffstat (limited to 'testsuites/psxtmtests/psxtmthread05/Makefile.am')
-rw-r--r--testsuites/psxtmtests/psxtmthread05/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/testsuites/psxtmtests/psxtmthread05/Makefile.am b/testsuites/psxtmtests/psxtmthread05/Makefile.am
new file mode 100644
index 0000000000..8c3cf66364
--- /dev/null
+++ b/testsuites/psxtmtests/psxtmthread05/Makefile.am
@@ -0,0 +1,27 @@
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxtmthread05
+psxtmthread05_SOURCES = init.c
+psxtmthread05_SOURCES += ../../tmtests/include/timesys.h
+psxtmthread05_SOURCES += ../../support/src/tmtests_empty_function.c
+psxtmthread05_SOURCES += ../../support/src/tmtests_support.c
+
+dist_rtems_tests_DATA = psxtmthread05.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+OPERATION_COUNT = @OPERATION_COUNT@
+AM_CPPFLAGS += -I$(top_srcdir)/../tmtests/include
+AM_CPPFLAGS += -DOPERATION_COUNT=$(OPERATION_COUNT)
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxtmthread05_OBJECTS) $(psxtmthread05_LDADD)
+LINK_LIBS = $(psxtmthread05_LDLIBS)
+
+psxtmthread05$(EXEEXT): $(psxtmthread05_OBJECTS) $(psxtmthread05_DEPENDENCIES)
+ @rm -f psxtmthread05$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am