summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtmtests/psxtmsem01/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-07-22 17:05:46 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-07-22 17:05:46 +0000
commitf31fcd44e48705e638e1acb9e975ceec8a37b187 (patch)
tree17d6a6a374ef0625010580ae86c5007e75b48e72 /testsuites/psxtmtests/psxtmsem01/Makefile.am
parent2011-07-22 Joel Sherrill <joel.sherrilL@OARcorp.com> (diff)
downloadrtems-f31fcd44e48705e638e1acb9e975ceec8a37b187.tar.bz2
2011-07-22 Ricardo Aguirre <el.mastin@ymail.com>
PR 1846/tests * Makefile.am, configure.ac, psxtmtests_plan.csv: Add benchmark of various sem_open(), sem_close(), sem_unlink(), sem_init(), and sem_destroy() cases. * psxtmsem01/.cvsignore, psxtmsem01/Makefile.am, psxtmsem01/init.c, psxtmsem01/psxtmsem01.doc: New files.
Diffstat (limited to 'testsuites/psxtmtests/psxtmsem01/Makefile.am')
-rw-r--r--testsuites/psxtmtests/psxtmsem01/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/testsuites/psxtmtests/psxtmsem01/Makefile.am b/testsuites/psxtmtests/psxtmsem01/Makefile.am
new file mode 100644
index 0000000000..23f58aa70b
--- /dev/null
+++ b/testsuites/psxtmtests/psxtmsem01/Makefile.am
@@ -0,0 +1,30 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxtmsem01
+psxtmsem01_SOURCES = init.c ../../tmtests/include/timesys.h \
+ ../../support/src/tmtests_empty_function.c \
+ ../../support/src/tmtests_support.c
+
+dist_rtems_tests_DATA = psxtmsem01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+OPERATION_COUNT = @OPERATION_COUNT@
+AM_CPPFLAGS += -I$(top_srcdir)/../tmtests/include
+AM_CPPFLAGS += -DOPERATION_COUNT=$(OPERATION_COUNT)
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxtmsem01_OBJECTS) $(psxtmsem01_LDADD)
+LINK_LIBS = $(psxtmsem01_LDLIBS)
+
+psxtmsem01$(EXEEXT): $(psxtmsem01_OBJECTS) $(psxtmsem01_DEPENDENCIES)
+ @rm -f psxtmsem01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am