summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtmtests/psxtmmutex02/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-12-06 16:35:31 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-12-06 16:35:31 +0000
commit519928c33386f1d6d5ef6cb9d34d93d2ef89c8a0 (patch)
tree74be705b7729a84fd13ad6d997bf2202909ab837 /testsuites/psxtmtests/psxtmmutex02/Makefile.am
parent2010-12-03 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-519928c33386f1d6d5ef6cb9d34d93d2ef89c8a0.tar.bz2
2010-12-06 Joel Sherrill <joel.sherrill@oarcorp.com>
* .cvsignore, ChangeLog, Makefile.am, README, configure.ac, psxtmtests_plan.csv, psxtmmutex02/.cvsignore, psxtmmutex02/Makefile.am, psxtmmutex02/init.c, psxtmmutex02/psxtmmutex02.doc, psxtmthread01/.cvsignore, psxtmthread01/Makefile.am, psxtmthread01/init.c, psxtmthread01/psxtmthread01.doc, psxtmthread03/.cvsignore, psxtmthread03/Makefile.am, psxtmthread03/init.c, psxtmthread03/psxtmthread03.doc: New files.
Diffstat (limited to 'testsuites/psxtmtests/psxtmmutex02/Makefile.am')
-rw-r--r--testsuites/psxtmtests/psxtmmutex02/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/testsuites/psxtmtests/psxtmmutex02/Makefile.am b/testsuites/psxtmtests/psxtmmutex02/Makefile.am
new file mode 100644
index 0000000000..8072e1806d
--- /dev/null
+++ b/testsuites/psxtmtests/psxtmmutex02/Makefile.am
@@ -0,0 +1,30 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxtmmutex02
+psxtmmutex02_SOURCES = init.c ../../tmtests/include/timesys.h \
+ ../../support/src/tmtests_empty_function.c \
+ ../../support/src/tmtests_support.c
+
+dist_rtems_tests_DATA = psxtmmutex02.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+OPERATION_COUNT = @OPERATION_COUNT@
+AM_CPPFLAGS += -I$(top_srcdir)/../tmtests/include
+AM_CPPFLAGS += -DOPERATION_COUNT=$(OPERATION_COUNT)
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxtmmutex02_OBJECTS) $(psxtmmutex02_LDADD)
+LINK_LIBS = $(psxtmmutex02_LDLIBS)
+
+psxtmmutex02$(EXEEXT): $(psxtmmutex02_OBJECTS) $(psxtmmutex02_DEPENDENCIES)
+ @rm -f psxtmmutex02$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am